all options
stretch-backports  ] [  buster  ] [  bullseye  ] [  bookworm  ] [  sid  ]
[ Source: unsafe-fences  ]

Package: libunsafe-fences-java (1.0-1.1)

Links for libunsafe-fences-java

Screenshot

Debian Resources:

Download Source Package unsafe-fences:

Maintainers:

External Resources:

Similar packages:

wrapper library around the Java 8 fences API

unsafe-fences is a very simple Java library that just provides a shim around the Java 8 Unsafe methods used for memory fencing.

In Java 8, three memory-ordering intrinsics were added to the sun.misc.Unsafe class: fullFence, storeFence, and loadFence.

The main goal of unsafe-fences is to allow code in Java 6 and 7 to compile those calls with a provided boolean guard.

This is especially useful for projects like JRuby that support several JDK versions but it can be reused by other Java projects as well.

Download libunsafe-fences-java

Download for all available architectures
Architecture Package Size Installed Size Files
all 4.9 kB25.0 kB [list of files]