all options
wheezy-backports  ] [  jessie  ] [  jessie-backports  ] [  stretch  ] [  buster  ] [  sid  ]
[ Source: needrestart  ]

Package: needrestart (2.11-3)

Links for needrestart

Screenshot

Debian Resources:

Download Source Package needrestart:

Maintainer:

External Resources:

Similar packages:

check which daemons need to be restarted after library upgrades

needrestart checks which daemons need to be restarted after library upgrades. It is inspired by checkrestart from the debian-goodies package.

Features:

 - supports (but does not require) systemd
 - binary blacklisting (i.e. display managers)
 - tries to detect required restarts of interpreter based daemons
   (supports Java, Perl, Python, Ruby)
 - tries to detect required resarts of  containers (docker, LXC)
 - tries to detect pending kernel upgrades
 - could be used as nagios check_command
 - fully integrated into apt/dpkg using hooks

Other Packages Related to needrestart

  • depends
  • recommends
  • suggests
  • enhances

Download needrestart

Download for all available architectures
Architecture Package Size Installed Size Files
all 45.7 kB227.0 kB [list of files]