all options
stretch  ] [  buster  ] [  sid  ]
[ Source: nettle  ]

Package: libhogweed4 (3.3-1 and others)

Links for libhogweed4

Screenshot

Debian Resources:

Download Source Package nettle:

Maintainer:

External Resources:

Similar packages:

low level cryptographic library (public-key cryptos)

Nettle is a cryptographic library that is designed to fit easily in more or less any context: In crypto toolkits for object-oriented languages (C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in kernel space.

It tries to solve a problem of providing a common set of cryptographic algorithms for higher-level applications by implementing a context-independent set of cryptographic algorithms. In that light, Nettle doesn't do any memory allocation or I/O, it simply provides the cryptographic algorithms for the application to use in any environment and in any way it needs.

This package contains the asymmetric cryptographic algorithms, which, require the GNU multiple precision arithmetic library (libgmp) for their large integer computations.

Other Packages Related to libhogweed4

  • depends
  • recommends
  • suggests
  • enhances

Download libhogweed4

Download for all available architectures
Architecture Version Package Size Installed Size Files
amd64 3.3-1+b2 133.0 kB232.0 kB [list of files]
arm64 3.3-1+b2 125.2 kB216.0 kB [list of files]
armel 3.3-1+b2 122.9 kB199.0 kB [list of files]
armhf 3.3-1+b2 123.4 kB179.0 kB [list of files]
i386 3.3-1+b2 135.2 kB231.0 kB [list of files]
mips 3.3-1+b2 125.7 kB222.0 kB [list of files]
mips64el 3.3-1+b2 127.4 kB240.0 kB [list of files]
mipsel 3.3-1+b2 126.2 kB222.0 kB [list of files]
ppc64el 3.3-1+b2 128.7 kB280.0 kB [list of files]
s390x 3.3-1+b2 132.0 kB248.0 kB [list of files]