wszystkie opcje
jessie  ] [  stretch  ] [  buster  ] [  sid  ]
[ Pakiet źródłowy: ruby-commander  ]

Pakiet: ruby-commander (4.4.5-1)

Odnośniki dla ruby-commander

Screenshot

Zasoby systemu Debian:

Pobieranie pakietu źródłowego ruby-commander:

Opiekunowie:

Zasoby zewnętrzne:

Podobne pakiety:

Ruby command-line interface library

"Commander" bridges the gap between other terminal related libraries you know and love (OptionParser, HighLine), while providing many new features, and an elegant API.

Features:

   * Easier than baking cookies
   * Parses options using OptionParser
   * Auto-populates struct with options:
     ( no more { |v| options[:recursive] = v } )
   * Auto-generates help documentation via pluggable help formatters
   * Optional default command when none is present
   * Global / Command level options
   * Packaged with two help formatters (Terminal, TerminalCompact)
   * Imports the highline gem for interacting with the terminal
   * Adds additional user interaction functionality
   * Highly customizable progress bar with intuitive, simple usage
   * Multi-word command name support
   * Sexy paging for long bodies of text
   * Command aliasing
   * Use the 'commander' executable to initialize a commander driven program

Inne pakiety związane z ruby-commander

  • wymaga
  • poleca
  • sugeruje
  • enhances

Pobieranie ruby-commander

Pobierz dla wszystkich dostępnych architektur
Architektura Rozmiar pakietu Rozmiar po instalacji Pliki
all 28,0 KiB102,0 KiB [lista plików]