wszystkie opcje
jessie  ] [  stretch  ] [  buster  ] [  bullseye  ] [  sid  ]
[ Pakiet źródłowy: molly-guard  ]

Pakiet: molly-guard (0.7.2)

Odnośniki dla molly-guard

Screenshot

Zasoby systemu Debian:

Pobieranie pakietu źródłowego molly-guard:

Opiekunowie:

Podobne pakiety:

protects machines from accidental shutdowns/reboots

The package installs a shell script that overrides the existing shutdown/reboot/halt/poweroff/coldreboot/pm-hibernate/pm-suspend* commands and first runs a set of scripts, which all have to exit successfully, before molly-guard invokes the real command.

One of the scripts checks for existing SSH sessions. If any of the four commands are called interactively over an SSH session, the shell script prompts you to enter the name of the host you wish to shut down. This should adequately prevent you from accidental shutdowns and reboots.

molly-guard diverts the real binaries to /lib/molly-guard/. You can bypass molly-guard by running those binaries directly.

Znaczniki: Zaimplementowane w: Powłoki sh, bash, ksh, tcsh i inne, Interfejs użytkownika: Wiersz poleceń, Sieć: network::server, protocol::ssh, Rola: Program, Zakres: Narzędzie

Inne pakiety związane z molly-guard

  • wymaga
  • poleca
  • sugeruje
  • enhances

Pobieranie molly-guard

Pobierz dla wszystkich dostępnych architektur
Architektura Rozmiar pakietu Rozmiar po instalacji Pliki
all 14,1 KiB56,0 KiB [lista plików]