wszystkie opcje
stretch  ] [  buster  ] [  bullseye  ] [  bookworm  ] [  sid  ]
[ Pakiet źródłowy: pugl  ]

Pakiet: libpugl-0-0 (0~svn32+dfsg0-3)

Odnośniki dla libpugl-0-0

Screenshot

Zasoby systemu Debian:

Pobieranie pakietu źródłowego pugl:

Opiekun:

Zasoby zewnętrzne:

Podobne pakiety:

portable API for OpenGL graphical interfaces

Pugl is a minimal portable API for OpenGL GUIs which supports embedding and is suitable for use in plugins, but can also be used for programs.

Pugl is vaguely similar to GLUT, but with some significant distinctions:

 * Minimal in scope, providing only what is necessary to draw
   and receive keyboard and mouse input.
 * No reliance on static data whatsoever, so the API can be
   used in plugins or multiple independent parts of a program.
 * Single implementation, which is small, liberally licensed
   and suitable for direct inclusion in programs if avoiding a
   library dependency is desired.
 * Support for embedding in other windows, so Pugl code can
   draw to a widget inside a larger GUI.
 * More complete support for keyboard input, including
   additional “special” keys, modifiers, and support for
   detecting individual modifier key presses.

Inne pakiety związane z libpugl-0-0

  • wymaga
  • poleca
  • sugeruje
  • enhances

Pobieranie libpugl-0-0

Pobierz dla wszystkich dostępnych architektur
Architektura Rozmiar pakietu Rozmiar po instalacji Pliki
amd64 8,0 KiB40,0 KiB [lista plików]
arm64 7,7 KiB32,0 KiB [lista plików]
armel 8,0 KiB31,0 KiB [lista plików]
armhf 7,3 KiB27,0 KiB [lista plików]
i386 7,9 KiB35,0 KiB [lista plików]
mips64el 7,7 KiB37,0 KiB [lista plików]
mipsel 7,5 KiB32,0 KiB [lista plików]
ppc64el 8,1 KiB84,0 KiB [lista plików]
s390x 8,0 KiB36,0 KiB [lista plików]