alle opties
wheezy  ] [  wheezy-backports  ] [  jessie  ] [  jessie-backports  ] [  stretch  ] [  buster  ] [  sid  ]
[ Bron: pkg-kde-tools  ]

Pakket: libdlrestrictions1 (0.15.3)

Verwijzigingen voor libdlrestrictions1

Screenshot

Debian bronnen:

Het bronpakket pkg-kde-tools downloaden:

Beheerders:

Vergelijkbare pakketten:

library that implements library compatibility checks for dlopen()

This package provides a DLRestrictions library that can be used to check compatibility of the external shared library (or plugin) against other libraries currently loaded in the global symbol object. It might help to avoid symbol clashes and provide means for graceful failure detection in advance before the first dlsym() call. Otherwise, usage of incompatible library might result in crashes or other unpredictable failures of the application.

A shared library that is protected by DLRestrictions provides a special symbol which defines conditions under which the library may be safely used. At the moment, the only restriction that may be imposed controls whether multiple SONAMEs of the same library can safely co-exist in the same symbol space. Shared library dependencies are also checked for compatibility.

Tags: Implemented in: C, Role: Shared Library

Andere aan libdlrestrictions1 gerelateerde pakketten

  • depends
  • recommends
  • suggests
  • enhances

libdlrestrictions1 downloaden

Pakket downloaden voor alle beschikbare platforms
Platform Pakketgrootte Geïnstalleerde grootte Bestanden
mipsel 19,6 kB58,0 kB [overzicht]