alle opties
squeeze  ] [  wheezy  ] [  jessie  ] [  sid  ]
[ Bron: abi-compliance-checker  ]

Pakket: abi-compliance-checker (1.97.7-1)

Verwijzigingen voor abi-compliance-checker

Screenshot

Debian bronnen:

Het bronpakket abi-compliance-checker downloaden:

Beheerders:

Externe bronnen:

Vergelijkbare pakketten:

tool to compare ABI compatibility of shared C/C++ library versions

abi-compliance-checker can be used to help reduce the possibility of an application crashing when the shared libraries it links against have changed. Signatures and data type definitions from two separate versions of a library are compared by examining the shared objects (.so) files themselves, and by analysing the header files (.h) provided for the two versions of the library and their dependencies.

Shared library developers trying to strive for binary compatibility between releases may also use this tool to detect if an any accidental application binary interface (ABI) changes have been introduced.

The checker may also be used for assessing binary compatibility between different Linux distributions.

Tags: Softwareontwikkeling: Testing and QA, Implemented in: Perl, Role: Program, Purpose: Checking

Andere aan abi-compliance-checker gerelateerde pakketten

  • depends
  • recommends
  • suggests
  • enhances

abi-compliance-checker downloaden

Pakket downloaden voor alle beschikbare platforms
Platform Pakketgrootte Geïnstalleerde grootte Bestanden
all 222,4 kB1.158,0 kB [overzicht]