alle opties
jessie  ] [  stretch  ] [  buster  ] [  bullseye  ] [  sid  ]
[ Bron: libpadwalker-perl  ]

Pakket: libpadwalker-perl (2.3-1 en anderen)

Verwijzigingen voor libpadwalker-perl

Screenshot

Debian bronnen:

Het bronpakket libpadwalker-perl downloaden:

Beheerders:

Externe bronnen:

Vergelijkbare pakketten:

module to inspect and manipulate lexical variables

PadWalker is a module that allows you to inspect and even modify lexical variables in the current "lexical pad stack." Perl tracks which variables are accessible and visible in each lexical scope by keeping a separate set of variables for each scope. This module looks for a given variable by traversing that stack, which allows it to alter anything in the stack, even variables not normally accessible in the current scope.

In practise, this module is useful for checking anything defined in the full stack of subroutines that called your function, making it extremely useful for debugging. It is, however, not recommended for use in production code.

Tags: Softwareontwikkeling: Ontwikkelen in Perl, Bibliotheken, Implemented in: implemented-in::c, implemented-in::perl, Role: Development Library

Andere aan libpadwalker-perl gerelateerde pakketten

  • depends
  • recommends
  • suggests
  • enhances

libpadwalker-perl downloaden

Pakket downloaden voor alle beschikbare platforms
Platform Versie Pakketgrootte Geïnstalleerde grootte Bestanden
amd64 2.3-1+b1 19,6 kB57,0 kB [overzicht]
arm64 2.3-1+b1 19,3 kB53,0 kB [overzicht]
armel 2.3-1+b1 18,3 kB49,0 kB [overzicht]
armhf 2.3-1+b1 18,2 kB49,0 kB [overzicht]
i386 2.3-1+b1 20,1 kB57,0 kB [overzicht]
mips 2.3-1+b1 18,8 kB54,0 kB [overzicht]
mips64el 2.3-1+b1 19,1 kB54,0 kB [overzicht]
mipsel 2.3-1+b1 18,9 kB54,0 kB [overzicht]
ppc64el 2.3-1+b1 20,3 kB101,0 kB [overzicht]
s390x 2.3-1+b1 19,2 kB53,0 kB [overzicht]