すべてのオプション
jessie  ] [  stretch  ] [  buster  ] [  bullseye  ] [  sid  ]
[ ソース: abi-compliance-checker  ]

パッケージ: abi-compliance-checker (1.99.9-2)

abi-compliance-checker に関するリンク

Screenshot

Debian の資源:

abi-compliance-checker ソースパッケージをダウンロード:

メンテナ:

外部の資源:

類似のパッケージ:

tool to compare ABI compatibility of shared C/C++ library versions

abi-compliance-checker can be used to help reduce the possibility of an application crashing when the shared libraries it links against have changed. Signatures and data type definitions from two separate versions of a library are compared by examining the shared objects (.so) files themselves, and by analysing the header files (.h) provided for the two versions of the library and their dependencies.

Shared library developers trying to strive for binary compatibility between releases may also use this tool to detect if an any accidental application binary interface (ABI) changes have been introduced.

The checker may also be used for assessing binary compatibility between different Linux distributions.

タグ: ソフトウェア開発: テストや QA, 実装言語: Perl, 役割: プログラム, 目的: 検査

その他の abi-compliance-checker 関連パッケージ

  • 依存
  • 推奨
  • 提案
  • enhances

abi-compliance-checker のダウンロード

すべての利用可能アーキテクチャ向けのダウンロード
アーキテクチャ パッケージサイズ インストールサイズ ファイル
all 225.9 kB1,541.0 kB [ファイル一覧]