all options
jessie  ] [  stretch  ] [  buster  ] [  bullseye  ] [  sid  ]
[ Source: libuniversal-require-perl  ]

Package: libuniversal-require-perl (0.18-1)

Links for libuniversal-require-perl

Screenshot

Debian Resources:

Download Source Package libuniversal-require-perl:

Maintainers:

External Resources:

Similar packages:

carica moduli da una variabile

Funziona esattamente come il require standard di Perl, tranne per il fatto di essere senza restrizioni sulle bareword e di non morire. Dato che require() è posizionato nello spazio dei nomi UNIVERSAL, funzionerà su qualsiasi modulo. Basta usare UNIVERSAL::require in qualsiasi posto del proprio codice.

Se è capitato di avere bisogno di fare questo:

   eval "require $modulo";

per aggirare i problemi sulle bareword di require(), questo modulo è ciò che ci vuole. Crea un metodo classe require() universale che funzionerà con qualsiasi modulo Perl ed è sicuro. Quindi, invece di fare del complicato lavoro eval(), si può usare:

   $modulo->require;

Non fa risparmiare molta scrittura, ma sarà molto più comprensibile per chi non è una cintura nera di Perl.

viene fornito anche un metodo use() che funziona in modo simile.

Other Packages Related to libuniversal-require-perl

  • depends
  • recommends
  • suggests
  • enhances

Download libuniversal-require-perl

Download for all available architectures
Architecture Package Size Installed Size Files
all 9.0 kB24.0 kB [list of files]