toutes les options
bookworm  ] [  sid  ]
[ Paquet source : php-composer-pcre  ]

Paquet : php-composer-pcre (3.1.0-1)

Liens pour php-composer-pcre

Screenshot

Ressources Debian :

Télécharger le paquet source php-composer-pcre :

Responsables :

Ressources externes :

Paquets similaires :

PCRE wrapping library that offers type-safe preg_* replacements

This library gives you a way to ensure `preg_*` functions do not fail silently, returning unexpected `null`s that may not be handled.

It also makes it easier to work with static analysis tools like PHPStan or Psalm as it simplifies and reduces the possible return values from all the `preg_*` functions which are quite packed with edge cases.

This library is a thin wrapper around `preg_*` functions with some limitations. If you are looking for a richer API to handle regular expressions have a look at rawr/t-regx instead.

Composer helps you declare, manage and install dependencies of PHP projects, ensuring you have the right stack everywhere.

Autres paquets associés à php-composer-pcre

  • dépendances
  • recommandations
  • suggestions
  • enhances

Télécharger php-composer-pcre

Télécharger pour toutes les architectures proposées
Architecture Taille du paquet Espace occupé une fois installé Fichiers
all 9,7 ko53,0 ko [liste des fichiers]