Alle Optionen
jessie  ] [  stretch  ] [  buster  ] [  bullseye  ] [  sid  ]
[ Quellcode: libtest-needsdisplay-perl  ]

Paket: libtest-needsdisplay-perl (1.07-3)

Links für libtest-needsdisplay-perl

Screenshot

Debian-Ressourcen:

Quellcode-Paket libtest-needsdisplay-perl herunterladen:

Betreuer:

Externe Ressourcen:

Ähnliche Pakete:

module to ensure that tests needing a display have one

When testing GUI applications, sometimes applications or modules absolutely insist on a display, even just to load a module without actually showing any objects.

Regardless, this makes GUI applications pretty much impossible to build and test on headless or automated systems. And it fails to the point of not even running the Makefile.PL script because a dependency needs a display so it can be loaded to find a version.

In these situations, what is needed is a fake display.

The Test::NeedsDisplay module will search around and try to find a way to load some sort of display that can be used for the testing.

Markierungen: Software-Entwicklung: Perl-Entwicklung, Bibliotheken, Implementiert in: Perl, Rolle: Laufzeit-Bibliothek

Andere Pakete mit Bezug zu libtest-needsdisplay-perl

  • hängt ab von
  • empfiehlt
  • schlägt vor
  • erweitert

libtest-needsdisplay-perl herunterladen

Download für alle verfügbaren Architekturen
Architektur Paketgröße Größe (installiert) Dateien
all 7,5 kB21,0 kB [Liste der Dateien]