Alle Optionen
bullseye  ] [  bookworm  ] [  sid  ]
[ Quellcode:  ]

Paket: libnettle8 (3.7.3-1) [debports]

Links für libnettle8

Screenshot

Debian-Ressourcen:

Quellcode-Paket herunterladen:

Nicht gefunden

Betreuer:

Externe Ressourcen:

Ähnliche Pakete:

Elementare Kryptografiebibliothek (symmetrische und Einweg-Kryptografie)

Nettle ist eine Kryptografiebibliothek, die für eine leichte Integration in eine Vielzahl von Anwendungen entworfen ist: in Kryptografie-Werkzeugsammlungen für objektorientierte Sprachen (C++, Python, Pike, ...), in Anwendungen wie LSH oder GNUPG oder sogar im Kernel.

Nettle implementiert einen Satz gebräuchlicher, kontextunabhängiger kryptografischer Algorithmen und versucht auf diese Weise kryptografische Algorithmen für auf höherer Ebene arbeitende Programme zur Verfügung zu stellen. Daher kümmert sich nettle nicht um Speicherverwaltung oder Ein-/Ausgabe. Sie stellt der Anwendung einfach nur universell einsetzbare Kryptografie zur Verfügung.

Dieses Paket enthält die symmetrischen und Einweg-Kryptografiealgorithmen. Um eine Abhängigkeit dieses Pakets von libgmp zu vermeiden, befinden sich die asymmetrischen Kryptografiealgorithmen in der separaten Bibliothek libhogweed.

Andere Pakete mit Bezug zu libnettle8

  • hängt ab von
  • empfiehlt
  • schlägt vor
  • erweitert

libnettle8 herunterladen

Download für alle verfügbaren Architekturen
Architektur Paketgröße Größe (installiert) Dateien
x32 (inoffizielle Portierung) 263,9 kB463,0 kB [Liste der Dateien]