Alle Optionen
stretch  ] [  buster  ] [  bullseye  ] [  bookworm  ] [  sid  ]
[ Quellcode: libstrictures-perl  ]

Paket: libstrictures-perl (2.000006-1)

Links für libstrictures-perl

Screenshot

Debian-Ressourcen:

Quellcode-Paket libstrictures-perl herunterladen:

Betreuer:

Externe Ressourcen:

Ähnliche Pakete:

Modul zur Aktivierung von »strict« und zur Umwandlung von Warnungen in Fehler

strictures aktiviert »strict« und erklärt alle Warnungen zu schwerwiegenden (fatalen) Fehlern. Falls das Modul innerhalb von Testfällen aus VCS-Checkouts ausgeführt wird, wird es auch dazu führen, dass Bareword-Dateihandles (ein Bareword ist ein einzelnes Wort ohne Anführungszeichen), indirekte Objektsyntax und die Emulation mehrdimensionaler Arrays einen schwerwiegenden Fehler auslösen. Um diese Prüfungen tatsächlich einzuschalten und um strictures nicht über fehlende Module klagen zu lassen, müssen die empfohlenen Pakete libbareword-filehandles-perl, libindirect-perl und libmultidimensional-perl installiert werden.

Markierungen: Software-Entwicklung: Perl-Entwicklung, Bibliotheken, Implementiert in: Perl, Rolle: Laufzeit-Bibliothek

Andere Pakete mit Bezug zu libstrictures-perl

  • hängt ab von
  • empfiehlt
  • schlägt vor
  • erweitert

libstrictures-perl herunterladen

Download für alle verfügbaren Architekturen
Architektur Paketgröße Größe (installiert) Dateien
all 18,1 kB41,0 kB [Liste der Dateien]