all options
jessie  ] [  stretch  ] [  buster  ] [  bullseye  ] [  sid  ]
[ Source: libuniversal-require-perl  ]

Package: libuniversal-require-perl (0.18-1)

Links for libuniversal-require-perl

Screenshot

Debian Resources:

Download Source Package libuniversal-require-perl:

Maintainers:

External Resources:

Similar packages:

Indlæs moduler fra en variabel

Dette virker præcis som standarden krævet i Perl, undtagen uden bareword-begrænsningen, og den dør ikke. Da require() er placeret i UNIVERSAL-navnerum, vil den virke på alle moduler. Du skal bare bruge UNIVERSAL::require et sted i din kode.

Hvis du har brugt dette ...

   eval "require $module";

for at komme omkring bareword caveats på require(), så er dette modul for dig. Det opretter en universel require()-klassemetode som vil fungere med alle Perlmoduler og den er sikker. Så i stedet for at udføre ondsindet eval()-arbejde, kan du gøre følgende:

   $module->require;

Det sparer dig ikke meget indtastning, men det vil give meget mere mening for en som ikke er professor i niende grad i Perl.

Tilbyder også en use()-metode, som virker på samme måde.

Other Packages Related to libuniversal-require-perl

  • depends
  • recommends
  • suggests
  • enhances

Download libuniversal-require-perl

Download for all available architectures
Architecture Package Size Installed Size Files
all 9.0 kB24.0 kB [list of files]